Unity Extras: Main Page

Unity Extras 1.0.0
A library of generic methods and extra functionality for the Unity Game Engine.
  • Main Page
  • Related Pages
  • Namespaces
  • Classes
Unity Extras Documentation

Introduction

Unity Extras is a pair of DLLs for use with the Unity Game Engine.

These libraries provide generic methods to Unity methods that do not have their own generic methods, as well providing some extra functionality.

The libraries are split into two namespaces:

  • UnityEngineExtras which provides functionality for UnityEngine.
  • UnityEditorExtras which provides functionality for UnityEditor (and does not apply to items outside the editor).

These libraries will work with Unity 4.5 and later.

All examples or snippets related to code are in C#. While these libraries might work with JavaScript or Boo, they have not been tested in either.

To use these libraries, place UnityEngineExtras.dll in the root Assets folder and UnityEditorExtras.dll into a folder named named Editor under the Assets folder. (This will be done for you if you use the Unity package.) Then include using statements for either UnityEngineExtras or UnityEditorExtras with the rest of your using statements. For example:

using UnityEngineExtras;
using UnityEditorExtras;

Please note that under Unity 5, the following methods in these libraries should either not be used or it is recommended not to use them:

  • AssetBundleGeneric.Load (use Unity's AssetBundle.LoadAsset instead)
  • AssetBundleGeneric.LoadAll (use Unity's AssetBundle.LoadAllAssets instead)
  • AssetBundleGeneric.LoadAsync (use Unity's AssetBundle.LoadAssetAsync instead)
  • ComponentGeneric.GetComponent with string argument (use Unity's Component.GetComponent with generic type instead)
  • GameObjectGeneric.AddComponent with string argument (use Unity's GameObject.AddComponent with generic type instead)
  • GameObjectGeneric.GetComponent with string argument (use Unity's GameObject.GetComponent with generic type instead)
  • ObjectGeneric.Instantiate (use Unity's Object.Instantiate instead)

If you are using Unity 4.5 or Unity 4.6, with the exception of the Component and GameObject methods, the above methods are still valid.

Contact

Unity Extras was created by Naram Qashat. He can be reached in the following ways:

  • Email: cyber.nosp@m.botx.nosp@m.@cybe.nosp@m.rbot.nosp@m.x.com
  • IRC: jenna.cyberbotx.com (typically under the username CyberBotX)
  • Unity Forums: CyberBotX-CBX
  • AOL Instant Messenger: CyberBotX2
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: Changelog

  • Related Pages
  • Namespaces
  • Classes
Changelog

Table of Contents

  • UnityExtras v1.0.0

UnityExtras v1.0.0

(Release date XXXX-XX-XX)

  • Initial release
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Namespace List

  • Namespace List
Namespace List
Here is a list of all documented namespaces with brief descriptions:
[detail level 12]
▼N UnityEditorExtras | A collection of extra methods and functionality for UnityEditor
N VersionControl |
N UnityEngineExtras | A collection of extra methods and functionality for UnityEngine


Unity Extras: UnityEditorExtras Namespace Reference

  • Namespace List
Namespaces | Classes
UnityEditorExtras Namespace Reference

A collection of extra methods and functionality for UnityEditor. More...

Namespaces

Classes

class | AnimationUtilityGeneric
Generic methods for the UnityEditor.AnimationUtility class. More...
class | AssetDatabaseGeneric
Generic methods for the UnityEditor.AssetDatabase class. More...
class | AssetPreviewGeneric
Generic methods for the UnityEditor.AssetPreview class. More...
class | Editor
Generic version of UnityEditor.Editor with the target and targets properties cast to an Object subtype. More...
class | EditorGeneric
Generic methods for the UnityEditor.Editor class. More...
class | EditorGUIExtras
Additional GUI element for UnityEditor.EditorGUI. More...
class | EditorGUIGeneric
Generic methods for the UnityEditor.EditorGUI class. More...
class | EditorGUILayoutExtras
A collection of EditorGUILayout versions of UnityEditor.EditorGUI methods. More...
class | EditorGUILayoutGeneric
Generic methods for the UnityEditor.EditorGUILayout class. More...
class | EditorGUIUtilityGeneric
Generic methods for the UnityEditor.EditorGUIUtility class. More...
class | EditorUtilityGeneric
Generic methods for the UnityEditor.EditorUtility class. More...
class | MaterialPropertyGeneric
Generic methods for the UnityEditor.MaterialProperty class. More...
class | ObjectPreview
Generic version of UnityEditor.ObjectPreview with the target property cast to an Object subtype. More...
class | PropertyDrawer
Generic version of UnityEditor.PropertyDrawer with the attribute property cast to a PropertyAttribute subtype. More...
class | SelectionGeneric
Generic methods for the UnityEditor.Selection class. More...
class | SerializedObjectGeneric
Generic methods for the UnityEditor.SerializedObject class. More...

Detailed Description

A collection of extra methods and functionality for UnityEditor.

Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.VersionControl Namespace Reference

  • Namespace List
  • UnityEditorExtras
  • VersionControl
Classes
UnityEditorExtras.VersionControl Namespace Reference

Classes

class AssetGeneric
Generic methods for the UnityEditor.VersionControl.Asset class. More...


Unity Extras: UnityEngineExtras Namespace Reference

  • Namespace List
Classes
UnityEngineExtras Namespace Reference

A collection of extra methods and functionality for UnityEngine. More...

Classes

class | AnimationClipGeneric
Generic methods for the UnityEngine.AnimationClip class. More...
class | AssetBundleGeneric
Generic methods for the UnityEngine.AssetBundle class. More...
class | ComponentGeneric
Generic methods for the UnityEngine.Component class. More...
class | GameObjectGeneric
Generic methods for the UnityEngine.GameObject class. More...
class | GUILayoutExtras
A collection of GUILayout versions of GUI methods. More...
class | GUIUtilityGeneric
Generic methods for the UnityEngine.GUIUtility class. More...
class | MathfExtras
Some System.Math methods that cast to float, missing from UnityEngine.Mathf. More...
class | NetworkGeneric
Generic methods for the UniteEngine.Network class. More...
class | ObjectGeneric
Generic methods for the UnityEngine.Object class. More...

Detailed Description

A collection of extra methods and functionality for UnityEngine.


Unity Extras: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
▼N UnityEditorExtras | A collection of extra methods and functionality for UnityEditor
▼N VersionControl |
C AssetGeneric | Generic methods for the UnityEditor.VersionControl.Asset class.
C AnimationUtilityGeneric | Generic methods for the UnityEditor.AnimationUtility class.
C AssetDatabaseGeneric | Generic methods for the UnityEditor.AssetDatabase class.
C AssetPreviewGeneric | Generic methods for the UnityEditor.AssetPreview class.
C Editor | Generic version of UnityEditor.Editor with the target and targets properties cast to an Object subtype.
C EditorGeneric | Generic methods for the UnityEditor.Editor class.
C EditorGUIExtras | Additional GUI element for UnityEditor.EditorGUI.
C EditorGUIGeneric | Generic methods for the UnityEditor.EditorGUI class.
C EditorGUILayoutExtras | A collection of EditorGUILayout versions of UnityEditor.EditorGUI methods.
C EditorGUILayoutGeneric | Generic methods for the UnityEditor.EditorGUILayout class.
C EditorGUIUtilityGeneric | Generic methods for the UnityEditor.EditorGUIUtility class.
C EditorUtilityGeneric | Generic methods for the UnityEditor.EditorUtility class.
C MaterialPropertyGeneric | Generic methods for the UnityEditor.MaterialProperty class.
C ObjectPreview | Generic version of UnityEditor.ObjectPreview with the target property cast to an Object subtype.
C PropertyDrawer | Generic version of UnityEditor.PropertyDrawer with the attribute property cast to a PropertyAttribute subtype.
C SelectionGeneric | Generic methods for the UnityEditor.Selection class.
C SerializedObjectGeneric | Generic methods for the UnityEditor.SerializedObject class.
▼N UnityEngineExtras | A collection of extra methods and functionality for UnityEngine
C AnimationClipGeneric | Generic methods for the UnityEngine.AnimationClip class.
C AssetBundleGeneric | Generic methods for the UnityEngine.AssetBundle class.
C ComponentGeneric | Generic methods for the UnityEngine.Component class.
C GameObjectGeneric | Generic methods for the UnityEngine.GameObject class.
C GUILayoutExtras | A collection of GUILayout versions of GUI methods.
C GUIUtilityGeneric | Generic methods for the UnityEngine.GUIUtility class.
C MathfExtras | Some System.Math methods that cast to float, missing from UnityEngine.Mathf.
C NetworkGeneric | Generic methods for the UniteEngine.Network class.
C ObjectGeneric | Generic methods for the UnityEngine.Object class.


Unity Extras: UnityEditorExtras.VersionControl.AssetGeneric Class Reference

  • Class Members
  • UnityEditorExtras
  • VersionControl
  • AssetGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.VersionControl.AssetGeneric Class Reference

Generic methods for the UnityEditor.VersionControl.Asset class. More...

Static Public Member Functions

static T Load< T > (this Asset asset)
Use as a replacement to casting VersionControl.Asset.Load to an Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.VersionControl.Asset class.

Member Function Documentation

static T UnityEditorExtras.VersionControl.AssetGeneric.Load< T > ( this Asset asset )
static

Use as a replacement to casting VersionControl.Asset.Load to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/VersionControl.Asset.Load.html

For example: asset.Load<Texture>() instead of asset.Load() as Texture.

Template Parameters
T Object or any Object subtype.
Returns
The asset cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.AnimationUtilityGeneric Class Reference

  • AnimationUtilityGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.AnimationUtilityGeneric Class Reference

Generic methods for the UnityEditor.AnimationUtility class. More...

Static Public Member Functions

static T GetAnimatedObject< T > (GameObject root, EditorCurveBinding binding)
Use as a replacement to casting AnimationUtility.GetAnimatedObject to an Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.AnimationUtility class.

Member Function Documentation

static T UnityEditorExtras.AnimationUtilityGeneric.GetAnimatedObject< T > | ( | GameObject | root,
 |  | EditorCurveBinding | binding
 | ) |  |
static

Use as a replacement to casting AnimationUtility.GetAnimatedObject to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/AnimationUtility.GetAnimatedObject.html

For example: AnimationUtilityGeneric.GetAnimatedObject<GameObject>(root, binding) instead of AnimationUtility.GetAnimatedObject(root, binding) as GameObject.

Template Parameters
T Object or any Object subtype.
Parameters
root | The root object.
binding | Curve binding the object.
Returns
The animated objected cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.AssetDatabaseGeneric Class Reference

  • AssetDatabaseGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.AssetDatabaseGeneric Class Reference

Generic methods for the UnityEditor.AssetDatabase class. More...

Static Public Member Functions

static T[] | LoadAllAssetRepresentationsAtPath< T > (string assetPath)
Use as a replacement to casting AssetDatabase.LoadAllAssetRepresentationsAtPath to an array of Object subtype. More...
static T[] | LoadAllAssetsAtPath< T > (string assetPath)
Use as a replacement to casting AssetDatabase.LoadAllAssetsAtPath to an array of Object subtype. More...
static T | LoadAssetAtPath< T > (string assetPath)
Use as a replacement to casting AssetDatabase.LoadAssetAtPath to an Object subtype. More...
static T | LoadMainAssetAtPath< T > (string assetPath)
Use as a replacement to casting AssetDatabase.LoadMainAssetAtPath to an Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.AssetDatabase class.

Member Function Documentation

static T [] UnityEditorExtras.AssetDatabaseGeneric.LoadAllAssetRepresentationsAtPath< T > ( string assetPath )
static

Use as a replacement to casting AssetDatabase.LoadAllAssetRepresentationsAtPath to an array of Object subtype.

See also: http://docs.unity3d.com/ScriptReference/AssetDatabase.LoadAllAssetRepresentationsAtPath.html

For example: AssetDatabaseGeneric.LoadAllAssetRepresentationsAtPath<Texture>(assetPath) instead of AssetDatabase.LoadAllAssetRepresentationsAtPath(assetPath).Cast<Texture>().ToArray().

Template Parameters
T Object or any Object subtype.
Parameters
assetPath Filesystem path to the asset.
Returns
Returns all asset representations at assetPath cast to T .
Type Constraints
T : Object
static T [] UnityEditorExtras.AssetDatabaseGeneric.LoadAllAssetsAtPath< T > ( string assetPath )
static

Use as a replacement to casting AssetDatabase.LoadAllAssetsAtPath to an array of Object subtype.

See also: http://docs.unity3d.com/ScriptReference/AssetDatabase.LoadAllAssetsAtPath.html

For example: AssetDatabaseGeneric.LoadAllAssetsAtPath<Texture>(assetPath) instead of AssetDatabase.LoadAllAssetsAtPath(assetPath).Cast<Texture>().ToArray().

Template Parameters
T Object or an Object subtype.
Parameters
assetPath Filesystem path to the asset.
Returns
Returns an array of all asset objects at assetPath cast to T .
Type Constraints
T : Object
static T UnityEditorExtras.AssetDatabaseGeneric.LoadAssetAtPath< T > ( string assetPath )
static

Use as a replacement to casting AssetDatabase.LoadAssetAtPath to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/AssetDatabase.LoadAssetAtPath.html

For example: AssetDatabaseGeneric.LoadAssetAtPath<Texture>(assetPath) instead of AssetDatabase.LoadAssetAtPath(assetPath, typeof(Texture)) as Texture.

Template Parameters
T Object or an Object subtype.
Parameters
assetPath Path of the asset to load.
Returns
Returns the first asset object of type T at given path assetPath cast to T .
Type Constraints
T : Object
static T UnityEditorExtras.AssetDatabaseGeneric.LoadMainAssetAtPath< T > ( string assetPath )
static

Use as a replacement to casting AssetDatabase.LoadMainAssetAtPath to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/AssetDatabase.LoadMainAssetAtPath.html

For example: AssetDatabaseGeneric.LoadMainAssetAtPath<Texture>(assetPath) instead of AssetDatabase.LoadMainAssetAtPath(assetPath) as Texture.

Template Parameters
T Object or an Object subtype.
Parameters
assetPath Filesystem path of the asset to load.
Returns
Returns the main asset object at assetPath cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.AssetPreviewGeneric Class Reference

  • AssetPreviewGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.AssetPreviewGeneric Class Reference

Generic methods for the UnityEditor.AssetPreview class. More...

Static Public Member Functions

static Texture2D GetMiniTypeThumbnail< T > ()
Use as a replacement to using typeof() when calling AssetPreview.GetMiniTypeThumbnail. More...

Detailed Description

Generic methods for the UnityEditor.AssetPreview class.

Member Function Documentation

static Texture2D UnityEditorExtras.AssetPreviewGeneric.GetMiniTypeThumbnail< T > ( )
static

Use as a replacement to using typeof() when calling AssetPreview.GetMiniTypeThumbnail.

See also: http://docs.unity3d.com/ScriptReference/AssetPreview.GetMiniTypeThumbnail.html

For example: AssetPreviewGeneric.GetMiniTypeThumbnail<Shader>() instead of AssetPreview.GetMiniTypeThumbnail(typeof(Shader)).

Returns
Returns the thumbnail for T .
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.Editor< T > Class Template Reference

  • Editor
Properties | List of all members
UnityEditorExtras.Editor< T > Class Template Reference

Generic version of UnityEditor.Editor with the target and targets properties cast to an Object subtype. More...

Inherits Editor.

Properties

new T | target [get]
The target of the base UnityEditor.Editor class, cast to T . More...
new T[] | targets [get]
The targets of the base UnityEditor.Editor class, cast to T . More...

Detailed Description

Generic version of UnityEditor.Editor with the target and targets properties cast to an Object subtype.

Template Parameters
T Object or any Object subtype.
Type Constraints
T : Object

Property Documentation

new T UnityEditorExtras.Editor< T >.target
get

The target of the base UnityEditor.Editor class, cast to T .

See also: http://docs.unity3d.com/ScriptReference/Editor-target.html

new T [] UnityEditorExtras.Editor< T >.targets
get

The targets of the base UnityEditor.Editor class, cast to T .

See also: http://docs.unity3d.com/ScriptReference/Editor-targets.html

Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorGeneric Class Reference

  • EditorGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.EditorGeneric Class Reference

Generic methods for the UnityEditor.Editor class. More...

Static Public Member Functions

static Editor | CreateEditor< T > (Object obj)
Use as a replacement to using typeof() when calling Editor.CreateEditor with a type argument. More...
static Editor | CreateEditor< T > (Object[] objects)
Use as a replacement to using typeof() when calling Editor.CreateEditor with a type argument. More...

Detailed Description

Generic methods for the UnityEditor.Editor class.

Member Function Documentation

static Editor UnityEditorExtras.EditorGeneric.CreateEditor< T > ( Object obj )
static

Use as a replacement to using typeof() when calling Editor.CreateEditor with a type argument.

See also: http://docs.unity3d.com/ScriptReference/Editor.CreateEditor.html

For example: EditorGeneric.CreateEditor<CustomEditor>(obj) instead of Editor.CreateEditor(obj, typeof(CustomEditor)).

Template Parameters
T Editor or any Editor subtype.
Parameters
obj The object to make a custom editor for.
Returns
The custom editor of type T .
Type Constraints
T : Editor
static Editor UnityEditorExtras.EditorGeneric.CreateEditor< T > ( Object[] objects )
static

Use as a replacement to using typeof() when calling Editor.CreateEditor with a type argument.

See also: http://docs.unity3d.com/ScriptReference/Editor.CreateEditor.html

For example: EditorGeneric.CreateEditor<CustomEditor>(objects) instead of Editor.CreateEditor(objects, typeof(CustomEditor)).

Template Parameters
T Editor or any Editor subtype.
Parameters
objects The objects to make a custom editor for.
Returns
The custom editor of type T .
Type Constraints
T : Editor
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorGUIExtras Class Reference

  • EditorGUIExtras
Static Public Member Functions | List of all members
UnityEditorExtras.EditorGUIExtras Class Reference

Additional GUI element for UnityEditor.EditorGUI. More...

Static Public Member Functions

static void HorizontalSplitter (Rect position, Color rgb, float thickness, RectOffset margin)
Draws a horizontal line splitter. More...

Detailed Description

Additional GUI element for UnityEditor.EditorGUI.

Currently this contains a horizontal line splitter element.

Member Function Documentation

static void UnityEditorExtras.EditorGUIExtras.HorizontalSplitter | ( | Rect | position,
 |  | Color | rgb,
 |  | float | thickness,
 |  | RectOffset | margin
 | ) |  |
static

Draws a horizontal line splitter.

If you wish to use the default values, there are versions of this method that exclude those arguments. For example, HorizontalSplitter(Rect position) uses the defaults for all the other arguments.

Parameters
position | Rectangle on the screen to use for the horizontal line splitter.
rgb | The color of the horizontal line splitter. Defaults to dark gray on pro skins and mid gray otherwise.
thickness | The thickness of the line. Defaults to 1.
margin | The margin surrounding the line. Defaults to no margin. Only the left and right values of the margin are used, due to how Unity renders the line.
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorGUIGeneric Class Reference

  • EditorGUIGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.EditorGUIGeneric Class Reference

Generic methods for the UnityEditor.EditorGUI class. More...

Static Public Member Functions

static T | EnumMaskField< T > (Rect position, T enumValue, GUIStyle style)
Use as a replacement to casting EditorGUI.EnumMaskField to an enumeration type. More...
static T | EnumMaskField< T > (Rect position, string label, T enumValue, GUIStyle style)
Use as a replacement to casting EditorGUI.EnumMaskField to an enumeration type. More...
static T | EnumMaskField< T > (Rect position, GUIContent label, T enumValue, GUIStyle style)
Use as a replacement to casting EditorGUI.EnumMaskField to an enumeration type. More...
static T | EnumPopup< T > (Rect position, T selected, GUIStyle style)
Use as a replacement to casting EditorGUI.EnumPopup to an enumeration type. More...
static T | EnumPopup< T > (Rect position, string label, T selected, GUIStyle style)
Use as a replacement to casting EditorGUI.EnumPopup to an enumeration type. More...
static T | EnumPopup< T > (Rect position, GUIContent label, T selected, GUIStyle style)
Use as a replacement to casting EditorGUI.EnumPopup to an enumeration type. More...
static T | ObjectField< T > (Rect position, T obj, bool allowSceneObjects)
Use as a replacement to casting EditorGUI.ObjectField to an Object subtype. More...
static T | ObjectField< T > (Rect position, string label, T obj, bool allowSceneObjects)
Use as a replacement to casting EditorGUI.ObjectField to an Object subtype. More...
static T | ObjectField< T > (Rect position, GUIContent label, T obj, bool allowSceneObjects)
Use as a replacement to casting EditorGUI.ObjectField to an Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.EditorGUI class.

Member Function Documentation

static T UnityEditorExtras.EditorGUIGeneric.EnumMaskField< T > | ( | Rect | position,
 |  | T | enumValue,
 |  | GUIStyle | style
 | ) |  |
static

Use as a replacement to casting EditorGUI.EnumMaskField to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.EnumMaskField.html

For example: EditorGUIGeneric.EnumMaskField(position, enumValue, style) will return the enumeration type of enumValue instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
position | Rectangle on the screen to use for this control.
enumValue | Enum to use for the flags.
style | Optional GUIStyle.
Returns
The value modified by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUIGeneric.EnumMaskField< T > | ( | Rect | position,
 |  | string | label,
 |  | T | enumValue,
 |  | GUIStyle | style
 | ) |  |
static

Use as a replacement to casting EditorGUI.EnumMaskField to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.EnumMaskField.html

For example: EditorGUIGeneric.EnumMaskField(position, label, enumValue, style) will return the enumeration type of enumValue instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
position | Rectangle on the screen to use for this control.
label | Caption/label for the control.
enumValue | Enum to use for the flags.
style | Optional GUIStyle.
Returns
The value modified by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUIGeneric.EnumMaskField< T > | ( | Rect | position,
 |  | GUIContent | label,
 |  | T | enumValue,
 |  | GUIStyle | style
 | ) |  |
static

Use as a replacement to casting EditorGUI.EnumMaskField to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.EnumMaskField.html

For example: EditorGUIGeneric.EnumMaskField(position, label, enumValue, style) will return the enumeration type of enumValue instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
position | Rectangle on the screen to use for this control.
label | Caption/label for the control.
enumValue | Enum to use for the flags.
style | Optional GUIStyle.
Returns
The value modified by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUIGeneric.EnumPopup< T > | ( | Rect | position,
 |  | T | selected,
 |  | GUIStyle | style
 | ) |  |
static

Use as a replacement to casting EditorGUI.EnumPopup to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.EnumPopup.html

For example: EditorGUIGeneric.EnumPopup(position, selected, style) will return the enumeration type of selected instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
position | Rectangle on the screen to use for the field.
selected | The enum option the field shows.
style | Optional GUIStyle.
Returns
The enum option that has been selected by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUIGeneric.EnumPopup< T > | ( | Rect | position,
 |  | string | label,
 |  | T | selected,
 |  | GUIStyle | style
 | ) |  |
static

Use as a replacement to casting EditorGUI.EnumPopup to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.EnumPopup.html

For example: EditorGUIGeneric.EnumPopup(position, label, selected, style) will return the enumeration type of selected instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
position | Rectangle on the screen to use for the field.
label | Optional label in front of the field.
selected | The enum option the field shows.
style | Optional GUIStyle.
Returns
The enum option that has been selected by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUIGeneric.EnumPopup< T > | ( | Rect | position,
 |  | GUIContent | label,
 |  | T | selected,
 |  | GUIStyle | style
 | ) |  |
static

Use as a replacement to casting EditorGUI.EnumPopup to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.EnumPopup.html

For example: EditorGUIGeneric.EnumPopup(position, label, selected, style) will return the enumeration type of selected instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
position | Rectangle on the screen to use for the field.
label | Optional label in front of the field.
selected | The enum option the field shows.
style | Optional GUIStyle.
Returns
The enum option that has been selected by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUIGeneric.ObjectField< T > | ( | Rect | position,
 |  | T | obj,
 |  | bool | allowSceneObjects
 | ) |  |
static

Use as a replacement to casting EditorGUI.ObjectField to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.ObjectField.html

For example: EditorGUIGeneric.ObjectField(position, obj, allowSceneObjects) instead of EditorGUI.ObjectField(position, obj, typeof(T), allowSceneObjects).

Template Parameters
T Object or any Object subtype.
Parameters
position | Rectangle on the screen to use for the field.
obj | The object the field shows.
allowSceneObjects | Allow assigning scene objects.
Returns
The object that has been set by the user cast type T .
Type Constraints
T : Object
static T UnityEditorExtras.EditorGUIGeneric.ObjectField< T > | ( | Rect | position,
 |  | string | label,
 |  | T | obj,
 |  | bool | allowSceneObjects
 | ) |  |
static

Use as a replacement to casting EditorGUI.ObjectField to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.ObjectField.html

For example: EditorGUIGeneric.ObjectField(position, label, obj, allowSceneObjects) instead of EditorGUI.ObjectField(position, label, obj, typeof(T), allowSceneObjects).

Template Parameters
T Object or any Object subtype.
Parameters
position | Rectangle on the screen to use for the field.
label | Optional label in front of the field.
obj | The object the field shows.
allowSceneObjects | Allow assigning scene objects.
Returns
The object that has been set by the user cast type T .
Type Constraints
T : Object
static T UnityEditorExtras.EditorGUIGeneric.ObjectField< T > | ( | Rect | position,
 |  | GUIContent | label,
 |  | T | obj,
 |  | bool | allowSceneObjects
 | ) |  |
static

Use as a replacement to casting EditorGUI.ObjectField to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.ObjectField.html

For example: EditorGUIGeneric.ObjectField(position, label, obj, allowSceneObjects) instead of EditorGUI.ObjectField(position, label, obj, typeof(T), allowSceneObjects).

Template Parameters
T Object or any Object subtype.
Parameters
position | Rectangle on the screen to use for the field.
label | Optional label in front of the field.
obj | The object the field shows.
allowSceneObjects | Allow assigning scene objects.
Returns
The object that has been set by the user cast type T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorGUILayoutExtras Class Reference

  • EditorGUILayoutExtras
Static Public Member Functions | List of all members
UnityEditorExtras.EditorGUILayoutExtras Class Reference

A collection of EditorGUILayout versions of UnityEditor.EditorGUI methods. More...

Static Public Member Functions

static void | DrawPreviewTexture (Texture image, Material mat, ScaleMode scaleMode, float imageAspect, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUI.DrawPreviewTexture. More...
static void | DrawTextureAlpha (Texture image, ScaleMode scaleMode, float imageAspect, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUI.DrawTextureAlpha. More...
static void | DropShadowLabel (GUIContent content, GUIStyle style, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUI.DropShadowLabel. More...
static void | HorizontalSplitter (Color rgb, float thickness, RectOffset margin, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUIExtras.HorizontalSplitter. More...
static void | MultiFloatField (GUIContent label, GUIContent[] subLabels, float[] values, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUI.MultiFloatField. More...
static void | MultiPropertyField (GUIContent[] subLabels, SerializedProperty valuesIterator, GUIContent label, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUI.MultiPropertyField. More...
static void | ProgressBar (float value, string text, params GUILayoutOption[] options)
EditorGUILayout version of EditorGUI.ProgressBar More...

Detailed Description

A collection of EditorGUILayout versions of UnityEditor.EditorGUI methods.

Currently this contains the following EditorGUILayout verisons of UnityEditor.EditorGUI methods:

  • DrawPreviewTexture
  • DrawTextureAlpha
  • DropShadowLabel
  • MultiFloatField
  • MultiPropertyField
  • ProgressBar

In addition, it also contains a EditorGUILayout version of this library's EditorGUIExtras.HorizontalSplitter method.

Member Function Documentation

static void UnityEditorExtras.EditorGUILayoutExtras.DrawPreviewTexture | ( | Texture | image,
 |  | Material | mat,
 |  | ScaleMode | scaleMode,
 |  | float | imageAspect,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUI.DrawPreviewTexture.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.DrawPreviewTexture.html

Parameters
image | Texture to display.
mat | Material to be used when drawing the texture.
scaleMode | How to scale the image when the aspect ratio of it doesn't fit the aspect ratio to be drawn within.
imageAspect | Aspect ratio to use for the source image. If 0 (the default), the aspect ratio from the image is used.
options | A set of GUILayoutOptions to use.
static void UnityEditorExtras.EditorGUILayoutExtras.DrawTextureAlpha | ( | Texture | image,
 |  | ScaleMode | scaleMode,
 |  | float | imageAspect,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUI.DrawTextureAlpha.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.DrawTextureAlpha.html

Parameters
image | Texture to display.
scaleMode | How to scale the image when the aspect ratio of it doesn't fit the aspect ratio to be drawn within.
imageAspect | Aspect ratio to use for the source image. If 0 (the default), the aspect ratio from the image is used.
options | A set of GUILayoutOptions to use.
static void UnityEditorExtras.EditorGUILayoutExtras.DropShadowLabel | ( | GUIContent | content,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUI.DropShadowLabel.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.DropShadowLabel.html

Parameters
content | Text to show.
style | Style to use.
options | A set of GUILayoutOptions to use.
static void UnityEditorExtras.EditorGUILayoutExtras.HorizontalSplitter | ( | Color | rgb,
 |  | float | thickness,
 |  | RectOffset | margin,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUIExtras.HorizontalSplitter.

Parameters
rgb | The color of the horizontal line splitter. Defaults to dark gray on pro skins and mid gray otherwise.
thickness | The thickness of the line. Defaults to 1.
margin | The margin surrounding the line. Defaults to no margin. Only the left and right values of the margin are used, due to how Unity renders the line.
options | A set of GUILayoutOptions to use.
static void UnityEditorExtras.EditorGUILayoutExtras.MultiFloatField | ( | GUIContent | label,
 |  | GUIContent[] | subLabels,
 |  | float[] | values,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUI.MultiFloatField.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.MultiFloatField.html

Parameters
label | Optional label to display in front of the float field.
subLabels | Array with small labels to show in front of each float field. There is room for one letter per field only.
values | Array with the values to edit.
options | A set of GUILayoutOptions to use.
static void UnityEditorExtras.EditorGUILayoutExtras.MultiPropertyField | ( | GUIContent[] | subLabels,
 |  | SerializedProperty | valuesIterator,
 |  | GUIContent | label,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUI.MultiPropertyField.

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.MultiPropertyField.html

Parameters
subLabels | Array with small labels to show in front of each float field. There is room for one letter per field only.
valuesIterator | The SerializedProperty of the first property to make a control for.
label | Optional label to use. If not specified the label of the property itself is used. Use GUIContent.none to not display a label at all.
options | A set of GUILayoutOptions to use.
static void UnityEditorExtras.EditorGUILayoutExtras.ProgressBar | ( | float | value,
 |  | string | text,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

EditorGUILayout version of EditorGUI.ProgressBar

See also: http://docs.unity3d.com/ScriptReference/EditorGUI.ProgressBar.html

Parameters
value | Value that is shown.
text | Text within progress bar.
options | A set of GUILayoutOptions to use.
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorGUILayoutGeneric Class Reference

  • EditorGUILayoutGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.EditorGUILayoutGeneric Class Reference

Generic methods for the UnityEditor.EditorGUILayout class. More...

Static Public Member Functions

static T | EnumMaskField< T > (T enumValue, GUIStyle style, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.EnumMaskField to an enumeration type. More...
static T | EnumMaskField< T > (string label, T enumValue, GUIStyle style, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.EnumMaskField to an enumeration type. More...
static T | EnumMaskField< T > (GUIContent label, T enumValue, GUIStyle style, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.EnumMaskField to an enumeration type. More...
static T | EnumPopup< T > (T selected, GUIStyle style, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.EnumPopup to an enumeration type. More...
static T | EnumPopup< T > (string label, T selected, GUIStyle style, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.EnumPopup to an enumeration type. More...
static T | EnumPopup< T > (GUIContent label, T selected, GUIStyle style, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.EnumPopup to an enumeration type. More...
static T | ObjectField< T > (T obj, bool allowSceneObjects, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.ObjectField to an Object subtype. More...
static T | ObjectField< T > (string label, T obj, bool allowSceneObjects, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.ObjectField to an Object subtype. More...
static T | ObjectField< T > (GUIContent label, T obj, bool allowSceneObjects, params GUILayoutOption[] options)
Use as a replacement to casting EditorGUILayout.ObjectField to an Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.EditorGUILayout class.

Member Function Documentation

static T UnityEditorExtras.EditorGUILayoutGeneric.EnumMaskField< T > | ( | T | enumValue,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.EnumMaskField to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.EnumMaskField.html

For example: EditorGUILayoutGeneric.EnumMaskField(enumValue, style, options) will return the enumeration type of enumValue instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
enumValue | Enum to use for the flags.
style | Optional GUIStyle.
options | An optional list of layout options that specify extra layouting properties. Any values passed in here will override settings defined by the style .
Returns
The value modified by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUILayoutGeneric.EnumMaskField< T > | ( | string | label,
 |  | T | enumValue,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.EnumMaskField to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.EnumMaskField.html

For example: EditorGUILayoutGeneric.EnumMaskField(label, enumValue, style, options) will return the enumeration type of enumValue instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
label | Prefix label for this field.
enumValue | Enum to use for the flags.
style | Optional GUIStyle.
options | An optional list of layout options that specify extra layouting properties. Any values passed in here will override settings defined by the style .
Returns
The value modified by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUILayoutGeneric.EnumMaskField< T > | ( | GUIContent | label,
 |  | T | enumValue,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.EnumMaskField to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.EnumMaskField.html

For example: EditorGUILayoutGeneric.EnumMaskField(label, enumValue, style, options) will return the enumeration type of enumValue instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
label | Prefix label for this field.
enumValue | Enum to use for the flags.
style | Optional GUIStyle.
options | An optional list of layout options that specify extra layouting properties. Any values passed in here will override settings defined by the style .
Returns
The value modified by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUILayoutGeneric.EnumPopup< T > | ( | T | selected,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.EnumPopup to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.EnumPopup.html

For example: EditorGUILayoutGeneric.EnumPopup(selected, style, options) will return the enumeration type of selected instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
selected | The enum option the field shows.
style | Optional GUIStyle.
options | An optional list of layout options that specify extra layouting properties. Any values passed in here will override settings defined by the style .
Returns
The enum option that has been selected by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUILayoutGeneric.EnumPopup< T > | ( | string | label,
 |  | T | selected,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.EnumPopup to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.EnumPopup.html

For example: EditorGUILayoutGeneric.EnumPopup(label, selected, style, options) will return the enumeration type of selected instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
label | Optional label in front of the field.
selected | The enum option the field shows.
style | Optional GUIStyle.
options | An optional list of layout options that specify extra layouting properties. Any values passed in here will override settings defined by the style .
Returns
The enum option that has been selected by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUILayoutGeneric.EnumPopup< T > | ( | GUIContent | label,
 |  | T | selected,
 |  | GUIStyle | style,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.EnumPopup to an enumeration type.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.EnumPopup.html

For example: EditorGUILayoutGeneric.EnumPopup(label, selected, style, options) will return the enumeration type of selected instead of System.Enum.

Template Parameters
T An enumeration type.
Parameters
label | Optional label in front of the field.
selected | The enum option the field shows.
style | Optional GUIStyle.
options | An optional list of layout options that specify extra layouting properties. Any values passed in here will override settings defined by the style .
Returns
The enum option that has been selected by the user cast to T .
Type Constraints
T : System.IComparable
T : System.IFormattable
T : System.IConvertible
static T UnityEditorExtras.EditorGUILayoutGeneric.ObjectField< T > | ( | T | obj,
 |  | bool | allowSceneObjects,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.ObjectField to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.ObjectField.html

For example: EditorGUILayoutGeneric.ObjectField(obj, allowSceneObjects, options) instead of EditorGUILayout.ObjectField(obj, typeof(T), allowSceneObjects, options).

Template Parameters
T Object or any Object subtype.
Parameters
obj | The object the field shows.
allowSceneObjects | Allow assigning scene objects.
options | An optional list of layout options that specify extra layout properties. Any values passed in here will override settings defined by the style.
Returns
The object that has been set by the user cast to T .
Type Constraints
T : Object
static T UnityEditorExtras.EditorGUILayoutGeneric.ObjectField< T > | ( | string | label,
 |  | T | obj,
 |  | bool | allowSceneObjects,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.ObjectField to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.ObjectField.html

For example: EditorGUILayoutGeneric.ObjectField(label, obj, allowSceneObjects, options) instead of EditorGUILayout.ObjectField(label, obj, typeof(T), allowSceneObjects, options).

Template Parameters
T Object or any Object subtype.
Parameters
label | Optional label in front of the field.
obj | The object the field shows.
allowSceneObjects | Allow assigning scene objects.
options | An optional list of layout options that specify extra layout properties. Any values passed in here will override settings defined by the style.
Returns
The object that has been set by the user cast to T .
Type Constraints
T : Object
static T UnityEditorExtras.EditorGUILayoutGeneric.ObjectField< T > | ( | GUIContent | label,
 |  | T | obj,
 |  | bool | allowSceneObjects,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

Use as a replacement to casting EditorGUILayout.ObjectField to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorGUILayout.ObjectField.html

For example: EditorGUILayoutGeneric.ObjectField(label, obj, allowSceneObjects, options) instead of EditorGUILayout.ObjectField(label, obj, typeof(T), allowSceneObjects, options).

Template Parameters
T Object or any Object subtype.
Parameters
label | Optional label in front of the field.
obj | The object the field shows.
allowSceneObjects | Allow assigning scene objects.
options | An optional list of layout options that specify extra layout properties. Any values passed in here will override settings defined by the style.
Returns
The object that has been set by the user cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorGUIUtilityGeneric Class Reference

  • EditorGUIUtilityGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.EditorGUIUtilityGeneric Class Reference

Generic methods for the UnityEditor.EditorGUIUtility class. More...

Static Public Member Functions

static bool | HasObjectThumbnail< T > ()
Use as a replacement to using typeof() when calling EditorGUIUtility.HasObjectThumbnail. More...
static GUIContent | ObjectContent< T > (Object obj)
Use as a replacement to using typeof() when calling EditorGUIUtility.ObjectContent. More...

Detailed Description

Generic methods for the UnityEditor.EditorGUIUtility class.

Member Function Documentation

static bool UnityEditorExtras.EditorGUIUtilityGeneric.HasObjectThumbnail< T > ( )
static

Use as a replacement to using typeof() when calling EditorGUIUtility.HasObjectThumbnail.

See also: http://docs.unity3d.com/ScriptReference/EditorGUIUtility.HasObjectThumbnail.html

For example: EditorGUIUtilityGeneric.HasObjectThumbnail<Texture>() instead of EditorGUIUtility.HasObjectThumbnail(typeof(Texture)).

Returns
True if a given class have per-object thumbnails, false otherwise.
static GUIContent UnityEditorExtras.EditorGUIUtilityGeneric.ObjectContent< T > ( Object obj )
static

Use as a replacement to using typeof() when calling EditorGUIUtility.ObjectContent.

See also: http://docs.unity3d.com/ScriptReference/EditorGUIUtility.ObjectContent.html

For example: EditorGUIUtilityGeneric.ObjectContent<Texture>(obj) instead of EditorGUIUtility.ObjectContent(obj, typeof(Texture)).

Parameters
obj Object to use for the returned content, can be null.
Returns
GUIContent object with the name and icon of an Object.
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.EditorUtilityGeneric Class Reference

  • EditorUtilityGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.EditorUtilityGeneric Class Reference

Generic methods for the UnityEditor.EditorUtility class. More...

Static Public Member Functions

static T[] | CollectDeepHierarchy< T > (Object[] roots)
Use as a replacement for casting EditorUtility.CollectDeepHierarchy to an array of Object subtype. More...
static T[] | CollectDependencies< T > (Object[] roots)
Use as a replacement for casting EditorUtility.CollectDependencies to an array of Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.EditorUtility class.

Member Function Documentation

static T [] UnityEditorExtras.EditorUtilityGeneric.CollectDeepHierarchy< T > ( Object[] roots )
static

Use as a replacement for casting EditorUtility.CollectDeepHierarchy to an array of Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorUtility.CollectDeepHierarchy.html

For example: EditorUtilityGeneric.CollectDeepHierarchy<GameObject>(roots) instead of EditorUtility.CollectDeepHierarchy(roots).Cast<GameObject>().ToArray().

Template Parameters
T Object or any Object subtype.
Parameters
roots Array of objects where the search will start.
Returns
Array of objects heirarchically attached to the search array cast to T .
Type Constraints
T : Object
static T [] UnityEditorExtras.EditorUtilityGeneric.CollectDependencies< T > ( Object[] roots )
static

Use as a replacement for casting EditorUtility.CollectDependencies to an array of Object subtype.

See also: http://docs.unity3d.com/ScriptReference/EditorUtility.CollectDependencies.html

For example: EditorUtilityGeneric.CollectDependencies<GameObject>(roots) instead of EditorUtility.CollectDependencies(roots).Cast<GameObject>().ToArray().

Template Parameters
T Object or any Object subtype.
Parameters
roots Array of objects where the search will start.
Returns
A list of all assets the assets listed in roots depend on cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.MaterialPropertyGeneric Class Reference

  • MaterialPropertyGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.MaterialPropertyGeneric Class Reference

Generic methods for the UnityEditor.MaterialProperty class. More...

Static Public Member Functions

static T[] GetTargets< T > (this MaterialProperty materialProperty)
Use as a replacement to casting MaterialProperty's targets property to an array of Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.MaterialProperty class.

Member Function Documentation

static T [] UnityEditorExtras.MaterialPropertyGeneric.GetTargets< T > ( this MaterialProperty materialProperty )
static

Use as a replacement to casting MaterialProperty's targets property to an array of Object subtype.

See also: http://docs.unity3d.com/ScriptReference/MaterialProperty-targets.html

For example: materialProperty.GetTargets<Texture>() instead of materialProperty.targets.Cast<Texture>().ToArra().

Template Parameters
T Object or any Object subtype.
Returns
Material objects being edited by this property cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.ObjectPreview< T > Class Template Reference

  • ObjectPreview
Properties | List of all members
UnityEditorExtras.ObjectPreview< T > Class Template Reference

Generic version of UnityEditor.ObjectPreview with the target property cast to an Object subtype. More...

Inherits ObjectPreview.

Properties

virtual new T target [get]
The target of the base UnityEditor.ObjectPreview class, cast to T . More...

Detailed Description

Generic version of UnityEditor.ObjectPreview with the target property cast to an Object subtype.

Template Parameters
T Object or any Object subtype.
Type Constraints
T : Object

Property Documentation

virtual new T UnityEditorExtras.ObjectPreview< T >.target
get

The target of the base UnityEditor.ObjectPreview class, cast to T .

See also: http://docs.unity3d.com/ScriptReference/ObjectPreview-target.html

Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.PropertyDrawer< T > Class Template Reference

  • PropertyDrawer
Properties | List of all members
UnityEditorExtras.PropertyDrawer< T > Class Template Reference

Generic version of UnityEditor.PropertyDrawer with the attribute property cast to a PropertyAttribute subtype. More...

Inherits PropertyDrawer.

Properties

new T attribute [get]
The attribute of the base UnityEditor.PropertyDrawer class, cast to T . More...

Detailed Description

Generic version of UnityEditor.PropertyDrawer with the attribute property cast to a PropertyAttribute subtype.

Template Parameters
T PropertyAttribute or any PropertyAttribute subtype.
Type Constraints
T : PropertyAttribute

Property Documentation

new T UnityEditorExtras.PropertyDrawer< T >.attribute
get

The attribute of the base UnityEditor.PropertyDrawer class, cast to T .

See also: http://docs.unity3d.com/ScriptReference/PropertyDrawer-attribute.html

Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.SelectionGeneric Class Reference

  • SelectionGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.SelectionGeneric Class Reference

Generic methods for the UnityEditor.Selection class. More...

Static Public Member Functions

static T[] GetFiltered< T > (SelectionMode mode)
Use as a replacement to using typeof() when calling Selection.GetFiltered. More...

Detailed Description

Generic methods for the UnityEditor.Selection class.

Member Function Documentation

static T [] UnityEditorExtras.SelectionGeneric.GetFiltered< T > ( SelectionMode mode )
static

Use as a replacement to using typeof() when calling Selection.GetFiltered.

See also: http://docs.unity3d.com/ScriptReference/Selection.GetFiltered.html

For example: SelectionGeneric.GetFiltered<GameObject>(mode) instead of Selection.GetFiltered(typeof(GameObject), mode).Cast<GameObject>().ToArray().

Template Parameters
T Object or any Object subtype.
Parameters
mode Further options to refine the selection.
Returns
Returns the current selection filtered by type and mode and cast to T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras.SerializedObjectGeneric Class Reference

  • SerializedObjectGeneric
Static Public Member Functions | List of all members
UnityEditorExtras.SerializedObjectGeneric Class Reference

Generic methods for the UnityEditor.SerializedObject class. More...

Static Public Member Functions

static T[] GetTargetObjects< T > (this SerializedObject so)
Use as a replacement to casting SerializedObject's targetObject property to an array of an Object subtype. More...

Detailed Description

Generic methods for the UnityEditor.SerializedObject class.

Member Function Documentation

static T [] UnityEditorExtras.SerializedObjectGeneric.GetTargetObjects< T > ( this SerializedObject so )
static

Use as a replacement to casting SerializedObject's targetObject property to an array of an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/SerializedObject-targetObjects.html

For example: so.GetTargetObjects<Texture>() instead of so.targetObject.Cast<Texture>().ToArray().

Template Parameters
T Object or any Object subtype.
Returns
The SerializedObject's targetObject property cast to an array of T .
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEngineExtras.AnimationClipGeneric Class Reference

  • UnityEngineExtras
  • AnimationClipGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.AnimationClipGeneric Class Reference

Generic methods for the UnityEngine.AnimationClip class. More...

Static Public Member Functions

static void SetCurve< T > (this AnimationClip clip, string relativePath, string propertyName, AnimationCurve curve)
Use as a replacement to using typeof() when calling AnimationClip.SetCurve. More...

Detailed Description

Generic methods for the UnityEngine.AnimationClip class.

Member Function Documentation

static void UnityEngineExtras.AnimationClipGeneric.SetCurve< T > | ( | this AnimationClip | clip,
 |  | string | relativePath,
 |  | string | propertyName,
 |  | AnimationCurve | curve
 | ) |  |
static

Use as a replacement to using typeof() when calling AnimationClip.SetCurve.

See also: http://docs.unity3d.com/ScriptReference/AnimationClip.SetCurve.html

For example: clip.SetCurve<Transform>("", "localPosition.x", curve) instead of clip.SetCurve("", typeof(Transform), "localPosition.x", curve).

Parameters
clip
relativePath | Path to the game object this curve applies to.
propertyName | The name or path of the property being animated.
curve | The animation curve.


Unity Extras: UnityEngineExtras.AssetBundleGeneric Class Reference

  • UnityEngineExtras
  • AssetBundleGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.AssetBundleGeneric Class Reference

Generic methods for the UnityEngine.AssetBundle class. More...

Static Public Member Functions

static T | Load< T > (this AssetBundle assetBundle, string name)
Use as a replacement to casting AssetBundle.Load to an Object subtype. More...
static T[] | LoadAll< T > (this AssetBundle assetBundle)
Use as a replacement to casting AssetBundle.LoadAll to an array of Object subtype. More...
static AssetBundleRequest | LoadAsync< T > (this AssetBundle assetBundle, string name)
Use as a replacement to using typeof() when calling AssetBundle.LoadAsync. More...

Detailed Description

Generic methods for the UnityEngine.AssetBundle class.

Member Function Documentation

static T UnityEngineExtras.AssetBundleGeneric.Load< T > | ( | this AssetBundle | assetBundle,
 |  | string | name
 | ) |  |
static

Use as a replacement to casting AssetBundle.Load to an Object subtype.

NOTE: If you are using Unity 5.0.0 or later, use AssetBundle.LoadAsset instead.

See also: http://docs.unity3d.com/450/Documentation/ScriptReference/AssetBundle.Load.html and http://docs.unity3d.com/ScriptReference/AssetBundle.LoadAsset.html

For example: assetBundle.Load<Shader>("name") instead of assetBundle.Load("name", typeof(Shader)) as Shader.

Template Parameters
T Object or any Object subtype.
Parameters
assetBundle
name The name of the object you want to load from the asset bundle.
Returns
The object loaded from the asset bundle named name cast to T .
Type Constraints
T : Object
static T [] UnityEngineExtras.AssetBundleGeneric.LoadAll< T > ( this AssetBundle assetBundle )
static

Use as a replacement to casting AssetBundle.LoadAll to an array of Object subtype.

NOTE: If you are using Unity 5.0.0 or later, use AssetBundle.LoadAllAssets instead.

See also: http://docs.unity3d.com/450/Documentation/ScriptReference/AssetBundle.LoadAll.html and http://docs.unity3d.com/ScriptReference/AssetBundle.LoadAllAssets.html

For example: assetBundle.LoadAll<Shader>() instead of assetBundle.LoadAll(typeof(Shader)).Cast<Shader>().ToArray().

Template Parameters
T Object or any Object subtype.
Returns
The objects loaded from the asset bundle cast to T .
Type Constraints
T : Object
static AssetBundleRequest UnityEngineExtras.AssetBundleGeneric.LoadAsync< T > | ( | this AssetBundle | assetBundle,
 |  | string | name
 | ) |  |
static

Use as a replacement to using typeof() when calling AssetBundle.LoadAsync.

NOTE: If you are using Unity 5.0.0 or later, use AssetBundle.LoadAssetAsync instead.

See also: http://docs.unity3d.com/450/Documentation/ScriptReference/AssetBundle.LoadAsync.html and http://docs.unity3d.com/ScriptReference/AssetBundle.LoadAssetAsync.html

For example: assetBundle.LoadAsync<Shader>("name") instead of assetBundle.LoadAsync("name") as Shader.

Parameters
assetBundle
name The name of the object you want to asynchronously load from the asset bundle.
Returns
The asynchronous bundle request for this call.


Unity Extras: UnityEngineExtras.ComponentGeneric Class Reference

  • UnityEngineExtras
  • ComponentGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.ComponentGeneric Class Reference

Generic methods for the UnityEngine.Component class. More...

Static Public Member Functions

static T GetComponent< T > (this Component component, string type)
Use as a replacement to casting Component.GetComponent(string type) to a Component subtype. More...

Detailed Description

Generic methods for the UnityEngine.Component class.

Member Function Documentation

static T UnityEngineExtras.ComponentGeneric.GetComponent< T > | ( | this Component | component,
 |  | string | type
 | ) |  |
static

Use as a replacement to casting Component.GetComponent(string type) to a Component subtype.

NOTE: It is recommended to use Component.GetComponent<T>() instead of this method.

See also: http://docs.unity3d.com/ScriptReference/Component.GetComponent.html

For example: component.GetComponent<Renderer>("Renderer") instead of component.GetComponent("Renderer") as Renderer.

Template Parameters
T Componnent or any Component subtype.
Parameters
component
type The name of the Component class you with to get.
Returns
The component class named type of the Component cast to T .
Type Constraints
T : Component
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEngineExtras.GameObjectGeneric Class Reference

  • UnityEngineExtras
  • GameObjectGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.GameObjectGeneric Class Reference

Generic methods for the UnityEngine.GameObject class. More...

Static Public Member Functions

static T | AddComponent< T > (this GameObject go, string className)
Use as a replacement to casting GameObject.AddComponent(string className) to a Component subtype. More...
static T | GetComponent< T > (this GameObject go, string type)
Use as a replacement to casting GameObject.GetComponent(string type) to a Component subtype. More...

Detailed Description

Generic methods for the UnityEngine.GameObject class.

Member Function Documentation

static T UnityEngineExtras.GameObjectGeneric.AddComponent< T > | ( | this GameObject | go,
 |  | string | className
 | ) |  |
static

Use as a replacement to casting GameObject.AddComponent(string className) to a Component subtype.

NOTE: This is deprecated in Unity 5.0.0 and later. It is recommended to use GameObject.AddComponent<T>() instead of this method.

See also: http://docs.unity3d.com/ScriptReference/GameObject.AddComponent.html

For example: go.AddComponent<Renderer>("Renderer") instead of go.AddComponent("Renderer") as Renderer.

Template Parameters
T Component or any Component subtype.
Parameters
go
className The name of the Component class you wish to add.
Returns
The component class named className of the GameObject cast to T .
Type Constraints
T : Component
static T UnityEngineExtras.GameObjectGeneric.GetComponent< T > | ( | this GameObject | go,
 |  | string | type
 | ) |  |
static

Use as a replacement to casting GameObject.GetComponent(string type) to a Component subtype.

NOTE: It is recommended to use GameObject.GetComponent<T>() instead of this method.

See also: http://docs.unity3d.com/ScriptReference/GameObject.GetComponent.html

For example: go.GetComponent<Renderer>("Renderer") instead of go.GetComponent("Renderer") as Renderer.

Template Parameters
T Component or any Component subtype.
Parameters
go
type The name of the Component class you wish to get.
Returns
The component class named type of the GameObject cast to T .
Type Constraints
T : Component
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEngineExtras.GUILayoutExtras Class Reference

  • UnityEngineExtras
  • GUILayoutExtras
Static Public Member Functions | List of all members
UnityEngineExtras.GUILayoutExtras Class Reference

A collection of GUILayout versions of GUI methods. More...

Static Public Member Functions

static void | DrawTexture (Texture image, ScaleMode scaleMode, bool alphaBlend, float imageAspect, params GUILayoutOption[] options)
GUILayout version of GUI.DrawTexture. More...
static void | DrawTextureWithTexCoords (Texture image, Rect texCoords, bool alphaBlend, params GUILayoutOption[] options)
GUILayout version of GUI.DrawTextureWithTexCoords. More...

Detailed Description

A collection of GUILayout versions of GUI methods.

Currently this contains two sets of GUILayout versions of GUI methods:

  • DrawTexture
  • DrawTextureWithTexCoords

Member Function Documentation

static void UnityEngineExtras.GUILayoutExtras.DrawTexture | ( | Texture | image,
 |  | ScaleMode | scaleMode,
 |  | bool | alphaBlend,
 |  | float | imageAspect,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

GUILayout version of GUI.DrawTexture.

See also: http://docs.unity3d.com/ScriptReference/GUI.DrawTexture.html

Parameters
image | Texture to display.
scaleMode | How to scale the image when the aspect ratio of it doesn't fit the aspect ratio to be drawn within. The default is StretchToFill.
alphaBlend | Whether to apply alpha blending when drawing the image (enabled by default).
imageAspect | Aspect ratio to use for the source image. If 0 (the default), the aspect ratio from the image is used. Pass in w/h for the desired aspect ratio. This allows the aspect ratio of the source image to be adjusted without changing the pixel width and height.
options | A set of GUILayoutOptions to use.
static void UnityEngineExtras.GUILayoutExtras.DrawTextureWithTexCoords | ( | Texture | image,
 |  | Rect | texCoords,
 |  | bool | alphaBlend,
 |  | params GUILayoutOption[] | options
 | ) |  |
static

GUILayout version of GUI.DrawTextureWithTexCoords.

See also: http://docs.unity3d.com/ScriptReference/GUI.DrawTextureWithTexCoords.html

Parameters
image | Texture to display.
texCoords | How to scale the image when the aspect ratio of it doesn't fit the aspect ratio to be drawn within.
alphaBlend | Whether to alpha blend the image on to the display (enabled the default). If false, the picture is drawn on to the display.
options | A set of GUILayoutOptions to use.


Unity Extras: UnityEngineExtras.GUIUtilityGeneric Class Reference

  • UnityEngineExtras
  • GUIUtilityGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.GUIUtilityGeneric Class Reference

Generic methods for the UnityEngine.GUIUtility class. More...

Static Public Member Functions

static T | GetStateObject< T > (int controlID)
Use this as a replacement to casting GUIUtility.GetStateObject. More...
static T | QueryStateObject< T > (int controlID)
Use this as a replacement to casting GUIUtility.QueryStateObject. More...

Detailed Description

Generic methods for the UnityEngine.GUIUtility class.

Member Function Documentation

static T UnityEngineExtras.GUIUtilityGeneric.GetStateObject< T > ( int controlID )
static

Use this as a replacement to casting GUIUtility.GetStateObject.

See also: http://docs.unity3d.com/ScriptReference/GUIUtility.GetStateObject.html

For example: GUIUtilityGeneric.GetStateObject<TextEditor>(controlID) instead of GUIUtility.GetStateObject(typeof(TextEditor), controlID) as TextEditor.

Returns
The state object for the given controlID cast to T .
static T UnityEngineExtras.GUIUtilityGeneric.QueryStateObject< T > ( int controlID )
static

Use this as a replacement to casting GUIUtility.QueryStateObject.

See also: http://docs.unity3d.com/ScriptReference/GUIUtility.QueryStateObject.html

For example: GUIUtilityGeneric.QueryStateObject<TextEditor>(controlID) instead of GUIUtility.QueryStateObject(typeof(TextEditor), controlID) as TextEditor.

Returns
The state object for the given controlID cast to T .


Unity Extras: UnityEngineExtras.MathfExtras Class Reference

  • UnityEngineExtras
  • MathfExtras
Static Public Member Functions | List of all members
UnityEngineExtras.MathfExtras Class Reference

Some System.Math methods that cast to float, missing from UnityEngine.Mathf. More...

Static Public Member Functions

static float | Cosh (float f)
Returns the hyperbolic cosine of the specified angle as a float. More...
static float | Sinh (float f)
Returns the hyperbolic sine of the specified angle as a float. More...
static float | Tanh (float f)
Returns the hyperbolic tangent of the specified angle as a float. More...
static float | Truncate (float f)
Calculates the integral part of a specified single-precision floating-point number. More...

Detailed Description

Some System.Math methods that cast to float, missing from UnityEngine.Mathf.

Member Function Documentation

static float UnityEngineExtras.MathfExtras.Cosh ( float f )
static

Returns the hyperbolic cosine of the specified angle as a float.

Parameters
f The angle, measured in radians.
Returns
The hyperbolic cosine of the specified angle as a float.
static float UnityEngineExtras.MathfExtras.Sinh ( float f )
static

Returns the hyperbolic sine of the specified angle as a float.

Parameters
f The angle, measured in radians.
Returns
The hyperbolic sine of the specified angle.
static float UnityEngineExtras.MathfExtras.Tanh ( float f )
static

Returns the hyperbolic tangent of the specified angle as a float.

Parameters
f The angle, measured in radians.
Returns
The hyperbolic tangent of the specified angle.
static float UnityEngineExtras.MathfExtras.Truncate ( float f )
static

Calculates the integral part of a specified single-precision floating-point number.

Parameters
f The number to truncate.
Returns
The integral part of f .


Unity Extras: UnityEngineExtras.NetworkGeneric Class Reference

  • UnityEngineExtras
  • NetworkGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.NetworkGeneric Class Reference

Generic methods for the UniteEngine.Network class. More...

Static Public Member Functions

static T Instantiate< T > (T prefab, Vector3 position, Quaternion rotation, int group)
Use this as a replacement to casting Network.Instantiate to an Object subtype. More...

Detailed Description

Generic methods for the UniteEngine.Network class.

Member Function Documentation

static T UnityEngineExtras.NetworkGeneric.Instantiate< T > | ( | T | prefab,
 |  | Vector3 | position,
 |  | Quaternion | rotation,
 |  | int | group
 | ) |  |
static

Use this as a replacement to casting Network.Instantiate to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/Network.Instantiate.html

For example: NetworkGeneric.Instantiate(GameObject prefab, position, rotation, group) will return a GameObject instead of an Object.

Template Parameters
T Object or any Object subtype.
Parameters
prefab | The prefab you wish to instantiate.
position | Position for the new object.
rotation | Orientation of the new object.
group | The network group number.
Returns
A network instantiated object with the same type as the prefab instead of Object.
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEngineExtras.ObjectGeneric Class Reference

  • UnityEngineExtras
  • ObjectGeneric
Static Public Member Functions | List of all members
UnityEngineExtras.ObjectGeneric Class Reference

Generic methods for the UnityEngine.Object class. More...

Static Public Member Functions

static T | Instantiate< T > (T original)
Use this as a replacement to casting Object.Instantiate to an Object subtype. More...
static T | Instantiate< T > (T original, Vector3 position, Quaternion rotation)
Use this as a replacement to casting Object.Instantiate to an Object subtype. More...

Detailed Description

Generic methods for the UnityEngine.Object class.

Member Function Documentation

static T UnityEngineExtras.ObjectGeneric.Instantiate< T > ( T original )
static

Use this as a replacement to casting Object.Instantiate to an Object subtype.

NOTE: If you are using Unity 5.0.0 or later, you do not need to use this method, as Object.Instantiate now has a generic version.

See also: http://docs.unity3d.com/ScriptReference/Object.Instantiate.html

For example: ObjectGeneric.Instantiate(GameObject original) will return a GameObject instead of an Object.

Template Parameters
T Object or any Object subtype.
Parameters
original An existing object that you want to make a copy of.
Returns
A clone of the original object with the same type as the original object instead of Object.
Type Constraints
T : Object
static T UnityEngineExtras.ObjectGeneric.Instantiate< T > | ( | T | original,
 |  | Vector3 | position,
 |  | Quaternion | rotation
 | ) |  |
static

Use this as a replacement to casting Object.Instantiate to an Object subtype.

See also: http://docs.unity3d.com/ScriptReference/Object.Instantiate.html

For example: ObjectGeneric.Instantiate(GameObject original, position, rotation) will return a GameObject instead of an Object.

Template Parameters
T Object or any Object subtype.
Parameters
original | An existing object that you want to make a copy of.
position | Position for the new object.
rotation | Orientation of the new object.
Returns
A clone of the original object with the same type as the original object instead of Object.
Type Constraints
T : Object
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: Class Index

Class Index
A | C | E | G | M | N | O | P | S
A
E
EditorUtilityGeneric (UnityEditorExtras) MathfExtras (UnityEngineExtras)
S
G
N
AnimationClipGeneric (UnityEngineExtras) Editor (UnityEditorExtras) SelectionGeneric (UnityEditorExtras)
AnimationUtilityGeneric (UnityEditorExtras) EditorGeneric (UnityEditorExtras) GameObjectGeneric (UnityEngineExtras) NetworkGeneric (UnityEngineExtras) SerializedObjectGeneric (UnityEditorExtras)
AssetBundleGeneric (UnityEngineExtras) EditorGUIExtras (UnityEditorExtras) GUILayoutExtras (UnityEngineExtras)
O
AssetDatabaseGeneric (UnityEditorExtras) EditorGUIGeneric (UnityEditorExtras) GUIUtilityGeneric (UnityEngineExtras)
AssetGeneric (UnityEditorExtras.VersionControl) EditorGUILayoutExtras (UnityEditorExtras)
M
ObjectGeneric (UnityEngineExtras)
AssetPreviewGeneric (UnityEditorExtras) EditorGUILayoutGeneric (UnityEditorExtras) ObjectPreview (UnityEditorExtras)
C
EditorGUIUtilityGeneric (UnityEditorExtras) MaterialPropertyGeneric (UnityEditorExtras)
P
ComponentGeneric (UnityEngineExtras) PropertyDrawer (UnityEditorExtras)
A | C | E | G | M | N | O | P | S


Unity Extras: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12]
C UnityEngineExtras.AnimationClipGeneric | Generic methods for the UnityEngine.AnimationClip class.
C UnityEditorExtras.AnimationUtilityGeneric | Generic methods for the UnityEditor.AnimationUtility class.
C UnityEngineExtras.AssetBundleGeneric | Generic methods for the UnityEngine.AssetBundle class.
C UnityEditorExtras.AssetDatabaseGeneric | Generic methods for the UnityEditor.AssetDatabase class.
C UnityEditorExtras.VersionControl.AssetGeneric | Generic methods for the UnityEditor.VersionControl.Asset class.
C UnityEditorExtras.AssetPreviewGeneric | Generic methods for the UnityEditor.AssetPreview class.
C UnityEngineExtras.ComponentGeneric | Generic methods for the UnityEngine.Component class.
▼C Editor |
C UnityEditorExtras.Editor< T > | Generic version of UnityEditor.Editor with the target and targets properties cast to an Object subtype.
C UnityEditorExtras.EditorGeneric | Generic methods for the UnityEditor.Editor class.
C UnityEditorExtras.EditorGUIExtras | Additional GUI element for UnityEditor.EditorGUI.
C UnityEditorExtras.EditorGUIGeneric | Generic methods for the UnityEditor.EditorGUI class.
C UnityEditorExtras.EditorGUILayoutExtras | A collection of EditorGUILayout versions of UnityEditor.EditorGUI methods.
C UnityEditorExtras.EditorGUILayoutGeneric | Generic methods for the UnityEditor.EditorGUILayout class.
C UnityEditorExtras.EditorGUIUtilityGeneric | Generic methods for the UnityEditor.EditorGUIUtility class.
C UnityEditorExtras.EditorUtilityGeneric | Generic methods for the UnityEditor.EditorUtility class.
C UnityEngineExtras.GameObjectGeneric | Generic methods for the UnityEngine.GameObject class.
C UnityEngineExtras.GUILayoutExtras | A collection of GUILayout versions of GUI methods.
C UnityEngineExtras.GUIUtilityGeneric | Generic methods for the UnityEngine.GUIUtility class.
C UnityEditorExtras.MaterialPropertyGeneric | Generic methods for the UnityEditor.MaterialProperty class.
C UnityEngineExtras.MathfExtras | Some System.Math methods that cast to float, missing from UnityEngine.Mathf.
C UnityEngineExtras.NetworkGeneric | Generic methods for the UniteEngine.Network class.
C UnityEngineExtras.ObjectGeneric | Generic methods for the UnityEngine.Object class.
▼C ObjectPreview |
C UnityEditorExtras.ObjectPreview< T > | Generic version of UnityEditor.ObjectPreview with the target property cast to an Object subtype.
▼C PropertyDrawer |
C UnityEditorExtras.PropertyDrawer< T > | Generic version of UnityEditor.PropertyDrawer with the attribute property cast to a PropertyAttribute subtype.
C UnityEditorExtras.SelectionGeneric | Generic methods for the UnityEditor.Selection class.
C UnityEditorExtras.SerializedObjectGeneric | Generic methods for the UnityEditor.SerializedObject class.


Unity Extras: Class Members

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • s
  • t
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AddComponent< T >() : UnityEngineExtras.GameObjectGeneric
  • attribute : UnityEditorExtras.PropertyDrawer< T >

- c -

  • CollectDeepHierarchy< T >() : UnityEditorExtras.EditorUtilityGeneric
  • CollectDependencies< T >() : UnityEditorExtras.EditorUtilityGeneric
  • Cosh() : UnityEngineExtras.MathfExtras
  • CreateEditor< T >() : UnityEditorExtras.EditorGeneric

- d -

  • DrawPreviewTexture() : UnityEditorExtras.EditorGUILayoutExtras
  • DrawTexture() : UnityEngineExtras.GUILayoutExtras
  • DrawTextureAlpha() : UnityEditorExtras.EditorGUILayoutExtras
  • DrawTextureWithTexCoords() : UnityEngineExtras.GUILayoutExtras
  • DropShadowLabel() : UnityEditorExtras.EditorGUILayoutExtras

- e -

  • EnumMaskField< T >() : UnityEditorExtras.EditorGUIGeneric , UnityEditorExtras.EditorGUILayoutGeneric
  • EnumPopup< T >() : UnityEditorExtras.EditorGUIGeneric , UnityEditorExtras.EditorGUILayoutGeneric

- g -

  • GetAnimatedObject< T >() : UnityEditorExtras.AnimationUtilityGeneric
  • GetComponent< T >() : UnityEngineExtras.ComponentGeneric , UnityEngineExtras.GameObjectGeneric
  • GetFiltered< T >() : UnityEditorExtras.SelectionGeneric
  • GetMiniTypeThumbnail< T >() : UnityEditorExtras.AssetPreviewGeneric
  • GetStateObject< T >() : UnityEngineExtras.GUIUtilityGeneric
  • GetTargetObjects< T >() : UnityEditorExtras.SerializedObjectGeneric
  • GetTargets< T >() : UnityEditorExtras.MaterialPropertyGeneric

- h -

  • HasObjectThumbnail< T >() : UnityEditorExtras.EditorGUIUtilityGeneric
  • HorizontalSplitter() : UnityEditorExtras.EditorGUIExtras , UnityEditorExtras.EditorGUILayoutExtras

- i -

  • Instantiate< T >() : UnityEngineExtras.NetworkGeneric , UnityEngineExtras.ObjectGeneric

- l -

  • Load< T >() : UnityEditorExtras.VersionControl.AssetGeneric , UnityEngineExtras.AssetBundleGeneric
  • LoadAll< T >() : UnityEngineExtras.AssetBundleGeneric
  • LoadAllAssetRepresentationsAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric
  • LoadAllAssetsAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric
  • LoadAssetAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric
  • LoadAsync< T >() : UnityEngineExtras.AssetBundleGeneric
  • LoadMainAssetAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric

- m -

  • MultiFloatField() : UnityEditorExtras.EditorGUILayoutExtras
  • MultiPropertyField() : UnityEditorExtras.EditorGUILayoutExtras

- o -

  • ObjectContent< T >() : UnityEditorExtras.EditorGUIUtilityGeneric
  • ObjectField< T >() : UnityEditorExtras.EditorGUIGeneric , UnityEditorExtras.EditorGUILayoutGeneric

- p -

  • ProgressBar() : UnityEditorExtras.EditorGUILayoutExtras

- q -

  • QueryStateObject< T >() : UnityEngineExtras.GUIUtilityGeneric

- s -

  • SetCurve< T >() : UnityEngineExtras.AnimationClipGeneric
  • Sinh() : UnityEngineExtras.MathfExtras

- t -

  • Tanh() : UnityEngineExtras.MathfExtras
  • target : UnityEditorExtras.Editor< T > , UnityEditorExtras.ObjectPreview< T >
  • targets : UnityEditorExtras.Editor< T >
  • Truncate() : UnityEngineExtras.MathfExtras


Unity Extras: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • s
  • t

- a -

  • AddComponent< T >() : UnityEngineExtras.GameObjectGeneric

- c -

  • CollectDeepHierarchy< T >() : UnityEditorExtras.EditorUtilityGeneric
  • CollectDependencies< T >() : UnityEditorExtras.EditorUtilityGeneric
  • Cosh() : UnityEngineExtras.MathfExtras
  • CreateEditor< T >() : UnityEditorExtras.EditorGeneric

- d -

  • DrawPreviewTexture() : UnityEditorExtras.EditorGUILayoutExtras
  • DrawTexture() : UnityEngineExtras.GUILayoutExtras
  • DrawTextureAlpha() : UnityEditorExtras.EditorGUILayoutExtras
  • DrawTextureWithTexCoords() : UnityEngineExtras.GUILayoutExtras
  • DropShadowLabel() : UnityEditorExtras.EditorGUILayoutExtras

- e -

  • EnumMaskField< T >() : UnityEditorExtras.EditorGUIGeneric , UnityEditorExtras.EditorGUILayoutGeneric
  • EnumPopup< T >() : UnityEditorExtras.EditorGUIGeneric , UnityEditorExtras.EditorGUILayoutGeneric

- g -

  • GetAnimatedObject< T >() : UnityEditorExtras.AnimationUtilityGeneric
  • GetComponent< T >() : UnityEngineExtras.ComponentGeneric , UnityEngineExtras.GameObjectGeneric
  • GetFiltered< T >() : UnityEditorExtras.SelectionGeneric
  • GetMiniTypeThumbnail< T >() : UnityEditorExtras.AssetPreviewGeneric
  • GetStateObject< T >() : UnityEngineExtras.GUIUtilityGeneric
  • GetTargetObjects< T >() : UnityEditorExtras.SerializedObjectGeneric
  • GetTargets< T >() : UnityEditorExtras.MaterialPropertyGeneric

- h -

  • HasObjectThumbnail< T >() : UnityEditorExtras.EditorGUIUtilityGeneric
  • HorizontalSplitter() : UnityEditorExtras.EditorGUIExtras , UnityEditorExtras.EditorGUILayoutExtras

- i -

  • Instantiate< T >() : UnityEngineExtras.NetworkGeneric , UnityEngineExtras.ObjectGeneric

- l -

  • Load< T >() : UnityEditorExtras.VersionControl.AssetGeneric , UnityEngineExtras.AssetBundleGeneric
  • LoadAll< T >() : UnityEngineExtras.AssetBundleGeneric
  • LoadAllAssetRepresentationsAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric
  • LoadAllAssetsAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric
  • LoadAssetAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric
  • LoadAsync< T >() : UnityEngineExtras.AssetBundleGeneric
  • LoadMainAssetAtPath< T >() : UnityEditorExtras.AssetDatabaseGeneric

- m -

  • MultiFloatField() : UnityEditorExtras.EditorGUILayoutExtras
  • MultiPropertyField() : UnityEditorExtras.EditorGUILayoutExtras

- o -

  • ObjectContent< T >() : UnityEditorExtras.EditorGUIUtilityGeneric
  • ObjectField< T >() : UnityEditorExtras.EditorGUIGeneric , UnityEditorExtras.EditorGUILayoutGeneric

- p -

  • ProgressBar() : UnityEditorExtras.EditorGUILayoutExtras

- q -

  • QueryStateObject< T >() : UnityEngineExtras.GUIUtilityGeneric

- s -

  • SetCurve< T >() : UnityEngineExtras.AnimationClipGeneric
  • Sinh() : UnityEngineExtras.MathfExtras

- t -

  • Tanh() : UnityEngineExtras.MathfExtras
  • Truncate() : UnityEngineExtras.MathfExtras


Unity Extras: Class Members - Properties

  • All
  • Functions
  • Properties
  • attribute : UnityEditorExtras.PropertyDrawer< T >
  • target : UnityEditorExtras.Editor< T > , UnityEditorExtras.ObjectPreview< T >
  • targets : UnityEditorExtras.Editor< T >


Unity Extras: Member List

  • AnimationUtilityGeneric
UnityEditorExtras.AnimationUtilityGeneric Member List

This is the complete list of members for UnityEditorExtras.AnimationUtilityGeneric, including all inherited members.

GetAnimatedObject< T >(GameObject root, EditorCurveBinding binding) UnityEditorExtras.AnimationUtilityGeneric static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • AssetDatabaseGeneric
UnityEditorExtras.AssetDatabaseGeneric Member List

This is the complete list of members for UnityEditorExtras.AssetDatabaseGeneric, including all inherited members.

LoadAllAssetRepresentationsAtPath< T >(string assetPath) | UnityEditorExtras.AssetDatabaseGeneric | static
LoadAllAssetsAtPath< T >(string assetPath) | UnityEditorExtras.AssetDatabaseGeneric | static
LoadAssetAtPath< T >(string assetPath) | UnityEditorExtras.AssetDatabaseGeneric | static
LoadMainAssetAtPath< T >(string assetPath) | UnityEditorExtras.AssetDatabaseGeneric | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • AssetPreviewGeneric
UnityEditorExtras.AssetPreviewGeneric Member List

This is the complete list of members for UnityEditorExtras.AssetPreviewGeneric, including all inherited members.

GetMiniTypeThumbnail< T >() UnityEditorExtras.AssetPreviewGeneric static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • Editor
UnityEditorExtras.Editor< T > Member List

This is the complete list of members for UnityEditorExtras.Editor< T >, including all inherited members.

target | UnityEditorExtras.Editor< T >
targets | UnityEditorExtras.Editor< T >
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorGUIExtras
UnityEditorExtras.EditorGUIExtras Member List

This is the complete list of members for UnityEditorExtras.EditorGUIExtras, including all inherited members.

HorizontalSplitter(Rect position, Color rgb, float thickness, RectOffset margin) UnityEditorExtras.EditorGUIExtras static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorGUIGeneric
UnityEditorExtras.EditorGUIGeneric Member List

This is the complete list of members for UnityEditorExtras.EditorGUIGeneric, including all inherited members.

EnumMaskField< T >(Rect position, T enumValue, GUIStyle style) | UnityEditorExtras.EditorGUIGeneric | static
EnumMaskField< T >(Rect position, string label, T enumValue, GUIStyle style) | UnityEditorExtras.EditorGUIGeneric | static
EnumMaskField< T >(Rect position, GUIContent label, T enumValue, GUIStyle style) | UnityEditorExtras.EditorGUIGeneric | static
EnumPopup< T >(Rect position, T selected, GUIStyle style) | UnityEditorExtras.EditorGUIGeneric | static
EnumPopup< T >(Rect position, string label, T selected, GUIStyle style) | UnityEditorExtras.EditorGUIGeneric | static
EnumPopup< T >(Rect position, GUIContent label, T selected, GUIStyle style) | UnityEditorExtras.EditorGUIGeneric | static
ObjectField< T >(Rect position, T obj, bool allowSceneObjects) | UnityEditorExtras.EditorGUIGeneric | static
ObjectField< T >(Rect position, string label, T obj, bool allowSceneObjects) | UnityEditorExtras.EditorGUIGeneric | static
ObjectField< T >(Rect position, GUIContent label, T obj, bool allowSceneObjects) | UnityEditorExtras.EditorGUIGeneric | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorGUILayoutExtras
UnityEditorExtras.EditorGUILayoutExtras Member List

This is the complete list of members for UnityEditorExtras.EditorGUILayoutExtras, including all inherited members.

DrawPreviewTexture(Texture image, Material mat, ScaleMode scaleMode, float imageAspect, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
DrawTextureAlpha(Texture image, ScaleMode scaleMode, float imageAspect, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
DropShadowLabel(GUIContent content, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
HorizontalSplitter(Color rgb, float thickness, RectOffset margin, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
MultiFloatField(GUIContent label, GUIContent[] subLabels, float[] values, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
MultiPropertyField(GUIContent[] subLabels, SerializedProperty valuesIterator, GUIContent label, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
ProgressBar(float value, string text, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutExtras | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorGUILayoutGeneric
UnityEditorExtras.EditorGUILayoutGeneric Member List

This is the complete list of members for UnityEditorExtras.EditorGUILayoutGeneric, including all inherited members.

EnumMaskField< T >(T enumValue, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
EnumMaskField< T >(string label, T enumValue, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
EnumMaskField< T >(GUIContent label, T enumValue, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
EnumPopup< T >(T selected, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
EnumPopup< T >(string label, T selected, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
EnumPopup< T >(GUIContent label, T selected, GUIStyle style, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
ObjectField< T >(T obj, bool allowSceneObjects, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
ObjectField< T >(string label, T obj, bool allowSceneObjects, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
ObjectField< T >(GUIContent label, T obj, bool allowSceneObjects, params GUILayoutOption[] options) | UnityEditorExtras.EditorGUILayoutGeneric | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorGUIUtilityGeneric
UnityEditorExtras.EditorGUIUtilityGeneric Member List

This is the complete list of members for UnityEditorExtras.EditorGUIUtilityGeneric, including all inherited members.

HasObjectThumbnail< T >() | UnityEditorExtras.EditorGUIUtilityGeneric | static
ObjectContent< T >(Object obj) | UnityEditorExtras.EditorGUIUtilityGeneric | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorGeneric
UnityEditorExtras.EditorGeneric Member List

This is the complete list of members for UnityEditorExtras.EditorGeneric, including all inherited members.

CreateEditor< T >(Object obj) | UnityEditorExtras.EditorGeneric | static
CreateEditor< T >(Object[] objects) | UnityEditorExtras.EditorGeneric | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • EditorUtilityGeneric
UnityEditorExtras.EditorUtilityGeneric Member List

This is the complete list of members for UnityEditorExtras.EditorUtilityGeneric, including all inherited members.

CollectDeepHierarchy< T >(Object[] roots) | UnityEditorExtras.EditorUtilityGeneric | static
CollectDependencies< T >(Object[] roots) | UnityEditorExtras.EditorUtilityGeneric | static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • MaterialPropertyGeneric
UnityEditorExtras.MaterialPropertyGeneric Member List

This is the complete list of members for UnityEditorExtras.MaterialPropertyGeneric, including all inherited members.

GetTargets< T >(this MaterialProperty materialProperty) UnityEditorExtras.MaterialPropertyGeneric static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • ObjectPreview
UnityEditorExtras.ObjectPreview< T > Member List

This is the complete list of members for UnityEditorExtras.ObjectPreview< T >, including all inherited members.

target UnityEditorExtras.ObjectPreview< T >
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • PropertyDrawer
UnityEditorExtras.PropertyDrawer< T > Member List

This is the complete list of members for UnityEditorExtras.PropertyDrawer< T >, including all inherited members.

attribute UnityEditorExtras.PropertyDrawer< T >
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • SelectionGeneric
UnityEditorExtras.SelectionGeneric Member List

This is the complete list of members for UnityEditorExtras.SelectionGeneric, including all inherited members.

GetFiltered< T >(SelectionMode mode) UnityEditorExtras.SelectionGeneric static
Generated on Sat Aug 27 2016 16:32:58 for Unity Extras by doxygen 1.8.11


Unity Extras: Member List

  • SerializedObjectGeneric
UnityEditorExtras.SerializedObjectGeneric Member List

This is the complete list of members for UnityEditorExtras.SerializedObjectGeneric, including all inherited members.

GetTargetObjects< T >(this SerializedObject so) UnityEditorExtras.SerializedObjectGeneric static


Unity Extras: Member List

  • VersionControl
  • AssetGeneric
UnityEditorExtras.VersionControl.AssetGeneric Member List

This is the complete list of members for UnityEditorExtras.VersionControl.AssetGeneric, including all inherited members.

Load< T >(this Asset asset) UnityEditorExtras.VersionControl.AssetGeneric static


Unity Extras: Member List

  • UnityEngineExtras
  • AnimationClipGeneric
UnityEngineExtras.AnimationClipGeneric Member List

This is the complete list of members for UnityEngineExtras.AnimationClipGeneric, including all inherited members.

SetCurve< T >(this AnimationClip clip, string relativePath, string propertyName, AnimationCurve curve) UnityEngineExtras.AnimationClipGeneric static


Unity Extras: Member List

  • UnityEngineExtras
  • AssetBundleGeneric
UnityEngineExtras.AssetBundleGeneric Member List

This is the complete list of members for UnityEngineExtras.AssetBundleGeneric, including all inherited members.

Load< T >(this AssetBundle assetBundle, string name) | UnityEngineExtras.AssetBundleGeneric | static
LoadAll< T >(this AssetBundle assetBundle) | UnityEngineExtras.AssetBundleGeneric | static
LoadAsync< T >(this AssetBundle assetBundle, string name) | UnityEngineExtras.AssetBundleGeneric | static


Unity Extras: Member List

  • UnityEngineExtras
  • ComponentGeneric
UnityEngineExtras.ComponentGeneric Member List

This is the complete list of members for UnityEngineExtras.ComponentGeneric, including all inherited members.

GetComponent< T >(this Component component, string type) UnityEngineExtras.ComponentGeneric static


Unity Extras: Member List

  • UnityEngineExtras
  • GUILayoutExtras
UnityEngineExtras.GUILayoutExtras Member List

This is the complete list of members for UnityEngineExtras.GUILayoutExtras, including all inherited members.

DrawTexture(Texture image, ScaleMode scaleMode, bool alphaBlend, float imageAspect, params GUILayoutOption[] options) | UnityEngineExtras.GUILayoutExtras | static
DrawTextureWithTexCoords(Texture image, Rect texCoords, bool alphaBlend, params GUILayoutOption[] options) | UnityEngineExtras.GUILayoutExtras | static


Unity Extras: Member List

  • UnityEngineExtras
  • GUIUtilityGeneric
UnityEngineExtras.GUIUtilityGeneric Member List

This is the complete list of members for UnityEngineExtras.GUIUtilityGeneric, including all inherited members.

GetStateObject< T >(int controlID) | UnityEngineExtras.GUIUtilityGeneric | static
QueryStateObject< T >(int controlID) | UnityEngineExtras.GUIUtilityGeneric | static


Unity Extras: Member List

  • UnityEngineExtras
  • GameObjectGeneric
UnityEngineExtras.GameObjectGeneric Member List

This is the complete list of members for UnityEngineExtras.GameObjectGeneric, including all inherited members.

AddComponent< T >(this GameObject go, string className) | UnityEngineExtras.GameObjectGeneric | static
GetComponent< T >(this GameObject go, string type) | UnityEngineExtras.GameObjectGeneric | static


Unity Extras: Member List

  • UnityEngineExtras
  • MathfExtras
UnityEngineExtras.MathfExtras Member List

This is the complete list of members for UnityEngineExtras.MathfExtras, including all inherited members.

Cosh(float f) | UnityEngineExtras.MathfExtras | static
Sinh(float f) | UnityEngineExtras.MathfExtras | static
Tanh(float f) | UnityEngineExtras.MathfExtras | static
Truncate(float f) | UnityEngineExtras.MathfExtras | static


Unity Extras: Member List

  • UnityEngineExtras
  • NetworkGeneric
UnityEngineExtras.NetworkGeneric Member List

This is the complete list of members for UnityEngineExtras.NetworkGeneric, including all inherited members.

Instantiate< T >(T prefab, Vector3 position, Quaternion rotation, int group) UnityEngineExtras.NetworkGeneric static


Unity Extras: Member List

  • UnityEngineExtras
  • ObjectGeneric
UnityEngineExtras.ObjectGeneric Member List

This is the complete list of members for UnityEngineExtras.ObjectGeneric, including all inherited members.

Instantiate< T >(T original) | UnityEngineExtras.ObjectGeneric | static
Instantiate< T >(T original, Vector3 position, Quaternion rotation) | UnityEngineExtras.ObjectGeneric | static


Unity Extras: Properties Directory Reference

  • Properties
Properties Directory Reference

Files

Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: Properties Directory Reference

  • UnityEngineExtras
  • Properties
Properties Directory Reference

Files

Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEngineExtras Directory Reference

  • UnityEngineExtras
UnityEngineExtras Directory Reference

Directories

Files

Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: UnityEditorExtras Directory Reference

UnityEditorExtras Directory Reference

Directories

Files

Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11


Unity Extras: Related Pages

Related Pages
Here is a list of all related documentation pages:
Changelog
Generated on Sat Aug 27 2016 16:32:59 for Unity Extras by doxygen 1.8.11